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Introduction

The USB Development System Software is designed to be used with the USB Development Board to assist the users
of Cypress USB IC’'s. The System Software provides users with a means of developing and debugging their own
firmware.

The System Software provides an interface which opens up the access to various components on the Development
Board, such as the Program ROM, Data RAM, I/O Space, and Registers. It also provides break point capability as
well as user code download capability and list file trace tracking.

General
The USB Development System Software is a Windows 3.1/Windows 95 application.

Minimum System Requirements

» A 80486 or Higher personal computer.

* Atleast 8MB of RAM.

» Atleast 10MB of free Hard Disk space.

*  Microsoft Windows version 3.1 or Windows 95.

* A 3.5-inch (1.44-MB) high-density floppy disk drive.

Software Installation (Win 3.1 & Windows 95)

In Windows 3.1, select the “File => Run” function in the Program Manager and type ANSETUP.EXE and press
<Enter> (where “A:" is the appropriate floppy disk drive).

OR

In Windows 95, select “Run” from the “Start Menu” and type A\SETUP.EXE and press <Enter> (where “A”: is the
appropriate floppy disk drive.

Follow the installation instruction in the setup program.

The installation program creates a USB Monitor Icon ,“CM8MONXxx" in the “CM8MONXxx" Program Group where
“xx" is the system software version number.




The USB Monitor/Debug Software

Getting Started

The USB Development System Software can be run by double clicking on the USB Monitor Icon. Communications
can be established by setting the COM Port to the same RS-232 port that connects to the Development Board. Once
the Development Board is connected and the software has loaded, the system software can download information to
the board or read information fromit, or control the operation of the Development Board.

Program Organization

The USB Development System Software provides two types of control for the system. The main menu is a typical
Windows pull down menu. In addition to the main menu there is also a number of windows and buttons to control
program functions. Figure 1 shows a view of the System Software when it is first started. The Data RAM,
Registers/Flags, View, System Status, and List File window panes are the only window panes initially showing after
start up. The Program RAM, 1/0O Space, Breakpoint and Download Object File window panes can be displayed by
using the View window buttons or menu (Download Object Fileis not available in the View menu).
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Windows and Button Controls

The 1/O Space, Data RAM, Program RAM, List File, Breakpoint and Download Object window panes are re-sizable
and can be moved to any location. The View, Registers/Flags, and System Status window panes are not re-sizable
but can be moved to any location within the main window.

View Button Window

The View Button Window contains “buttons” which control the display of windows ingida
the main program window. Clicking on the buttons will open or close the partig
window panes.

1/0 Space Button: Open/Close the 1/0 Space window.

Data RAM Button: Open/Close the Data RAM window.

Program RAM Button:  Open/Close the Program RAM window.

List File Button: Open/Close the List File window.

Registers Button: Open/Close the Registers/Flags window.
Satus Button: Open/Close the System Status window

Bkpt(s) Button: Open/Close the Breakpoints window.

Dnld Object Button: Open/Close the Download Object File window.

I/0O Space Window

The /O Space window provides the functions of

displaying and altering the contents of the 1/O Space
addresses. Four buttons are provided for changing the
contents of the 1/O Spacé\r_Sel, Wr_All, Rd_S4,

Rd_All. 110 Space

“Wr_Sel” will WRITE the highlighted address of th¢
I/O Space with the contents of the data input box. |
data input box is located above the data disp]00: Port 0O
window. “Wr_All" will WRITE the contents of the|(01: 0F Port 1 Data
data input box to the entire /O Space. Click on the dfj02: 10 Port 2 Data
input box or use “Shift-Enter” to input data in the inp 03: Port 3 Data
box. The data format can be changed to hexadecim4|04 - PO IntWask
binary form by clicking on théata Display Format
choices of “Hex” or “Binary”.

“Rd_Sel” will READ the highlighted address of the 1/0
Space. “Rd_All" will READ the entire contents of the
I/O Space. Use the scroll bar to scroll through all of the
available 1/0 Space addresses.




Data RAM Window

The Data RAM window provides the functions of
displaying and atering the contents of the Data
RAM. Four buttons are provided for changing the
contents of the Data RAM; Wr_Seal, Wr_All, Rd_Sdl,

Rd_All.
. s 08: 00 00 OO 0D OO OO OO OO
“Wr_Sel” will WRITE the highlighted address °1l]- 00 00 00 00 00 00 00 OO

the Data RAM \{vith the contents of the data in 18- 00 00 0O 00 OO0 0D 00 0D
pr. The -data Input box is |OC§.ted above the d} 20-00 00 OO0 OO0 OO OO OO OO
dlsplay window. “WI’_A"" will WRITE the 28-00 00 00 OO0 OO0 OO OO OO
contents of the data input box to the entire D§|3g- oo 00D 00D 00 00 00 OO0 OO
RAM. Click on the data input box or use “Shiffi3g- oo 00 00 00 00 00 00 00
Enter” to input data in the input box. 40- 00 O0 OO0 00 OO0 OO OO OO0
(48 00 00 00 00 OO OO OO OO
|50: 00 00 00 00D 00 0D 00 OO

Data RAM. “Rd_Al" will READ the entire
contents of the Data RAM. Use the scroll bar
scroll through all available Data RAM locations.

Program RAM Window

The Program RAM window provides the functio
of displaying and altering the contents of tHLHELEY

Program RAM. Four buttons are provided fi l—l—l—
changing the contents of the Program RA

Wr_Sel, Wr_All, Rd_Sel, Rd_All. T FF FF FF FF FF yyy¥yyvyy &

“Wr_Sel’ will WRITE the highlighted address o : FF FF FF FF FF yyyyyyyy
. FF FF FF FF FF yyyyyyyy

the Program RAM with the contents of the d
. . . FF FF FF FF FF yyyyyvyyy
input box. The data input box is located above
. . p - FF FF FF FF FF yy¥yyyyy

data display window. “Wr_All" will WRITE the FF FF FF FF FF Soveuoes
contents of the data input box to the entire Progr yyyyyyyy

RAM. Click on the data input box or use “Shi EE EE EE EE EE YYyyyyyy
Enter” to input data in the input box. yYyyvyyy

FF FF FF FF FF $99¥y¥¥¥y

“Rd_Sel” will READ the highlighted address of th : FF FF FF FF FF 395¥¥¥¥¥¥
Program RAM. “Rd_All" will READ the entire : FF FF FF FF FF ¥¥¥y¥¥¥¥¥
contents of the Program RAM. Use the scroll bar : FF FF FF FF FF 3¥yyyyyy
scroll through all available Program RAM location : FF FF FF FF FF 99yyyyvy

FF FF FF FF FF $99¥y¥¥¥y
FF FF FF FF FF y9yyyyyy

FF FF FF FF FF §¥¥¥¥¥¥¥ | 5




List File Window

ast File: o leppressonB-monn\blinler. It

0129 3D [D4] RLC -
0124 31 44 [05] HOY [b=x].A

012C 3F [D8] RET

012D -
012D ## —— Walk 0 through, sequentially. p
012F 30 [04] svap a.dsp

0130

0130 19 FF [04] HO¥Y A O0FFh

0132 01 00 [04] ADD A.0 -/ clear carry =

The List File window displays the current list file which has been loaded. The list file can be loaded by using the

File menu (the operation of the File menu is described in section 5.1) or by clicking on the “Load List File After
Download” in the Download Object File Window (see Download Object File Window in section 4.9). Scrolling
through the list file can be accomplished by using the scroll bar, arrow keys or “PgUp/PgDn” keys. By “double
clicking” on a line in the list file window, a break point can be set or removed. Whenever the state of the
development board toggles from a “Running” state to thepi®td” state the “highlighted” line in the list file will
reflect the current Program Counter contents.

Register s/Flags Window

The Register/Flags window displays the current values of the microcontroller registers and flags. The window wiill
update any time the Development Board toggles from a “Running” state t

window. The contents of the registers or flags can be changed by clicki
any of the display boxes, changing the contents, and pressing <Ente
<Return>.

System Status Window

The System Status window displays the current “Running” arpistd” status

of the Development Board. This window also has four buttons which controls
the run status of the Development BoaRlin will put the Development Board
into “run” state. Break will cause the Development Board to stop executil i el =
Sngle Sep will single step the Development Board one instruction at a ti
Get Watch will update the Registers/Flags window and the selected addre

the Data RAM and I/O Space windowsGet Watch can be turned on b
clicking on the “watch on” box. A check mark in the box indicates @Geit

Watch is on, no check mark indicates it is offtep Over executes an entir|

routine of a call instruction and then stops at the next address. Selecting I—
these buttons (excepun) causes updates to the Registers/Flags windows,

any highlighted fields in the Data RAM and 1/0O Space windows (dependingo
the preference settings, see section 5.4).




Breakpoints Window

The Breakpoints window displays the current breakpoints as well as providing the ability to Add, Delete, and Toggle
breakpoints. The “Add” button adds whatever address has | -
inputted into the “New Breakpoint Address” data input box. T| ks stk
“Delete” button will delete whatever breakpoint is current
highlighted. The “On/Off” button will toggle the highlighteq
breakpoint on and off. In order to use breakpoints, the Develop
Board must be running from “Program RAM” (see the U{
Development System User’s Guide).

Download Object File Window

The Download Object File window provides the function of downloading an object file to the “Program RAM”. The
“download” button downloads the object
file. The object file is a “*.rom” file output

by the assembler. This file can be testgd
once it is downloaded to the “Prograrjiiddlliil eyl
RAM”.  The “cancel” button cancels thg
downloading process. Clicking on th
“Load List File After Download” box will
automatically display the list file when af {blinker.rom
object file is loaded. A check mark in thf|bumin.rom
box indicates that “Load List File Aftef [5oestrom
Download” is on, no check mark indicatgq |gentest.rom
it is off. A “checksum” is available to ﬂ:sgt'lz“;'

ensure that the contents of the object f{' |;iest23 rom
are correct. This value should match thitest24.rom
checksum in the list file. To download a} litestx.rom

object file, the Development Board must |
running from “Program RAM” (see thdg
USB Development System Users Guide).

Obiect Files (rom) | Se: [




Main Menu

FileMenu

The File Menu contains only file functions associated with the “List File” and “Program RAM” windows.

Load List File:
Unload List File:

Download Object File:

Load Project:
Save Project:
Save Project As:
Exit:

View Menu

Load a selected List File (*.Ist) into the “List File Window”. A List File is the listing file
from the assembler displaying the program address listing of the assembled program.
Unload the currently loaded from the “List File Window”. After this operation the “List
File Window” will be empty.

Download an Object File to the “Program RAM”. The Object File is a “*.rom” file
output by the assembler. When this file is downloaded to the “Program RAM" it can be
tested. The board must be properly configured to load the Program RAM; see the USB
Development System User’s Guide.

Loads a project (setups, settings of windows and directory being used).

Saves the current project.

Saves the current project with a new name.

Close the USB Development System Software application.

The View Menu contains the selections for opening and closing all of the program window objects in the main
program window, except the Download Object File Window. Selecting an item is the same as clicking on a button in
the View window (see Section 4.1) except the View Menu contains an additional selection, “View Bar” as shown

below.

Data Ram:

1/0 Space:

List File:
Breakpoints:
View Bar:
Registers/Flags:
System Satus:
Program RAM:

System Menu

Open/Close the Data RAM window.
Open/Close the 1/0 Space window.
Open/Close the List File window.
Open/Close the Breakpoints window.
Open/Close the View Bar window.
Open/Close the Register/Flags window.
Open/Close the System Status windows.
Open/Close the Program RAM window.

The System Menu controls the “Run” status of the Development Board. Selecting an item is the same as clicking on
a button in the System Status window (see Section 4.7).

Run:

Break:
Sngle Sep:
Get Watch:
Sep Over:

Preferences Menu

Activate the “Run” status.

Break the “Run” status.

Single-Step the Development Board.

Poll the System Status.

Run from a call routine to the next address.

The Preferences Menu is used to control the status of different features of the Development Board.

Watch Includes DRAM Selection, 10 Sl:

When “Watch Includes DRAM Selection, 10 Sel” is selected, the “Registers/Flags”
window, the selected data in the “Data RAM” window, and the selected data in the “I/O
Space” window will update automatically when the monitor detects that the system has
halted.




Watch is Continuous When Target is Running:

When “Watch is Continuous When Target is Running” is selected, a “Get Watch” (see
System Status Window in section 4.7 for more information on “Get Watch”) is done
every second. (WARNING: This may corrupt USB data.)

I/0 Space Data Format: From this menu selection two data types are selectable for displaying the 1/O Space data
values: Hex Number Format or Binary Number Format.

Save Project on Exit: When “Save Project on Exit” is selected, a project is automatically saved when exiting.
Development Board Setup:
This menu selection is used to select the Development Board model being used.

Defaults

The Defaults menu contains one menu choic&dsiore Default Window Arrangement . Clicking on Restore
Default Window Arrangement will restore the original arrangement of the window panes.

Communications Menu

The Communication Menu contains menu selections to control the properties of the RS-232 Communications Port to
which the Development Board is connected.

Comm Port: Set the desired RS-232 Communications Port.

Timeout Interval: Set the Timeout Interval for communication failure determination.
Initialize Comm Port: Reinitialize Comm Port to recover from serial communication errors.
Help Menu

Help menu only contains program revision information.

About M8 Monitor: Displays program information dialog window showing program revision and copyright.




License

The USB Development System Software is licensed for use on a single PC equipped with the USB Development
System Development Board (Part# CY 3650, CY 3651). The software may be copied for backup purposes only.
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